其他帐号登录: 注册 登录
收藏 | 网站
金融学院
欢迎阅读收藏并分享

最好用的期货文华财经期货指标公式代码,

28
发表时间:2019-04-19 16:36

豆5分钟线
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
CROSS(MA10,MA5)||(CLOSE-MA5)>6,SK;
(MA5-CLOSE)>4,BP;
CROSS(MA5,MA10)||(MA5-CLOSE)>6,BK;
(CLOSE-MA5)>4,SP;
短线提款机
X0:=(OPEN);
X1:=HHV(X0,N1);
X2:=LLV(X0,N2);
X3:=(X1+X2)/2;
TMP:=X3-CLOSE;
DRAWLINE(TMP>0.00001,HIGH,TMP>0.00001,OPEN,COLORCYAN);
DRAWLINE(TMP>0.00001,LOW,TMP>0.00001,CLOSE,COLORCYAN);
DRAWLINE(TMP<-0.00001,HIGH,TMP<-0.00001,CLOSE,COLORRED);
DRAWLINE(TMP<-0.00001,LOW,TMP<-0.00001,OPEN,COLORRED);
DRAWLINE(ABS(TMP)<0.00001,LOW,ABS(TMP)<0.00001,OPEN,COLORWHITE);
DRAWLINE(ABS(TMP)<0.00001,HIGH,ABS(TMP)<0.00001,OPEN,COLORWHITE);
STICKLINE(TMP>0.00001,OPEN,CLOSE,COLORCYAN,1);
STICKLINE(TMP<-0.00001,OPEN,CLOSE,COLORRED,1);
TMP>0, buy;
TMP<0,sell;
参数:N1=21,N2=7
期价流
MA(MA(CLOSE,5),1);
MA(MA(CLOSE,5),2);
MA(MA(CLOSE,5),3);
MA(MA(CLOSE,5),4);
MA(MA(CLOSE,5),5);
MA(MA(CLOSE,5),6);
MA(MA(CLOSE,5),7);
MA(MA(CLOSE,5),8);
MA(MA(CLOSE,5),9);
MA(MA(CLOSE,5),10);
TMP:=OPEN-CLOSE;
SARLINE:=ABS(SAR(N,STEP,MVALUE));
DRAWLINE(CLOSE>SARLINE,HIGH,TMP>0.00001,OPEN,COLORRED);
DRAWLINE(CLOSE>SARLINE,LOW,TMP>0.00001,CLOSE,COLORRED);
DRAWLINE(CLOSE>SARLINE,HIGH,TMP<-0.00001,CLOSE,COLORRED);
DRAWLINE(CLOSE>SARLINE,LOW,TMP<-0.00001,OPEN,COLORRED);
DRAWLINE(CLOSE>SARLINE,LOW,ABS(TMP)<0.00001,OPEN,COLORRED);
DRAWLINE(CLOSE>SARLINE,HIGH,ABS(TMP)<0.00001,OPEN,COLORRED);
STICKLINE(TMP>0&&CLOSE>SARLINE,OPEN,CLOSE,COLORRED,0);
STICKLINE(TMP<=0&&CLOSE>SARLINE,OPEN,CLOSE,COLORRED,1);
DRAWLINE(CLOSE0.00001,OPEN,COLORCYAN);
DRAWLINE(CLOSE0.00001,CLOSE,COLORCYAN);
DRAWLINE(CLOSE<-0.00001,CLOSE,COLORCYAN);
DRAWLINE(CLOSE<-0.00001,OPEN,COLORCYAN);
DRAWLINE(CLOSE<0.00001,OPEN,COLORCYAN);
DRAWLINE(CLOSE<0.00001,OPEN,COLORCYAN);
STICKLINE(TMP>0&&CLOSE
STICKLINE(TMP<=0&&CLOSE
参数:N=4,STEP=0.013,MVALUE=0.2
期价流可执行
MA1:=MA(MA(CLOSE,5),1);
MA2:=MA(MA(CLOSE,5),2);
MA3:=MA(MA(CLOSE,5),3);
MA4:=MA(MA(CLOSE,5),4);
MA5:=MA(MA(CLOSE,5),5);
MA6:=MA(MA(CLOSE,5),6);
MA7:=MA(MA(CLOSE,5),7);
MA8:=MA(MA(CLOSE,5),8);
MA9:=MA(MA(CLOSE,5),9);
MA10:=MA(MA(CLOSE,5),10);
MA1>REF(MA1,1)&&MA2>REF(MA2,1)&&MA3>REF(MA3,1)&&MA4>REF(MA4,1)&&MA5>REF(MA5,1)
&&MA6>REF(MA6,1)&&MA7>REF(MA7,1)&&MA8>REF(MA8,1)&&MA9>REF(MA9,1)&&MA10>REF(MA10,1)
&&CLOSE
MA1
&&MA6
&&amp;CLOSE>OPEN&&CROSS(MA10,MA1),SPK;
后福通道
TMP:=OPEN-CLOSE;
DRAWLINE(TMP>0.00001,HIGH,TMP>0.00001,OPEN,COLORCYAN);
DRAWLINE(TMP>0.00001,LOW,TMP>0.00001,CLOSE,COLORCYAN);
DRAWLINE(TMP<-0.00001,HIGH,TMP<-0.00001,CLOSE,COLORRED);
DRAWLINE(TMP<-0.00001,LOW,TMP<-0.00001,OPEN,COLORRED);
DRAWLINE(ABS(TMP)<0.00001,LOW,ABS(TMP)<0.00001,OPEN,COLORWHITE);
DRAWLINE(ABS(TMP)<0.00001,HIGH,ABS(TMP)<0.00001,OPEN,COLORWHITE);
STICKLINE(TMP>0,OPEN,CLOSE,COLORCYAN,0);
STICKLINE(TMP<=0,OPEN,CLOSE,COLORRED,1);
A1:MA(HIGH,N),COLORWHITE;
A2:MA(LOW,N),COLORYELLOW;
B1:MA(HHV(HIGH,M),5),COLORGREEN;
B2:MA(LLV(LOW,M),5),COLORRED;
参数:N=5,M=5
离心率
CHA:=CLOSE-AVPRICE;
CHA<=0&&ABS(CHA)>=ABS(LLV(CHA,3))&&ABS(CHA)<=16,SK;
CHA>0&&ABS(CHA)>=ABS(HHV(CHA,3))&&CHA<=16,BK;
CHA1:=REF(CHA,1);
CHA2:=REF(CHA,2);
CHA<=0&&ABS(CHA1)<=ABS(CHA2)&&ABS(CHA)<=ABS(CHA1),BP;
CHA>0&&ABS(CHA1)>ABS(CHA2)&&ABS(CHA)>ABS(CHA1),SP;
参数:16(A)
KDJ应用
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
(CROSS(J,0)||((REF(K,1)<20)&&(REF(D,1)<20)&&(CROSS(K,D)))),BK;
CROSS(50,K),SP;
CROSS(K,50),BP;
(CROSS(100,J)||((D>80)&&(K>80)&&(CROSS(D,K)))),SK;
阴阳瀑布线
AA:=(OPEN+HIGH+LOW)/3;
PB1:PUBU(OPEN,0),COLORRED;
PB2:PUBU(OPEN,1),COLORGREEN;
PB3:PUBU(OPEN,2),COLORWHITE;
PB4:PUBU(OPEN,3),COLORYELLOW;
PB5:PUBU(OPEN,4),COLORMAGENTA;
PB6:PUBU(OPEN,5),COLORBLUE;
TMP:=PUBU(AA,3)-PUBU(AA,0);
DRAWLINE(TMP>0.00001,HIGH,TMP>0.00001,OPEN,COLORCYAN);
DRAWLINE(TMP>0.00001,LOW,TMP>0.00001,CLOSE,COLORCYAN);
DRAWLINE(TMP<-0.00001,HIGH,TMP<-0.00001,CLOSE,COLORRED);
DRAWLINE(TMP<-0.00001,LOW,TMP<-0.00001,OPEN,COLORRED);
DRAWLINE(ABS(TMP)<0.00001,LOW,ABS(TMP)<0.00001,OPEN,COLORWHITE);
DRAWLINE(ABS(TMP)<0.00001,HIGH,ABS(TMP)<0.00001,OPEN,COLORWHITE);
STICKLINE(TMP>0.00001,OPEN,CLOSE,COLORCYAN,0);
STICKLINE(TMP<-0.00001,OPEN,CLOSE,COLORRED,0);
期货指南针
STICKLINE(SMA(CLOSE,SHORT,X)
DRAWLINE(SMA(CLOSE,SHORT,X)
STICKLINE(SMA(CLOSE,SHORT,X)>SMA(CLOSE,LONG,X),OPEN,CLOSE,COLORRED,0);
DRAWLINE(SMA(CLOSE,SHORT,X)>SMA(CLOSE,LONG,X),HIGH,SMA(CLOSE,SHORT,X)>SMA(CLOSE,LONG,X),LOW,COLORRED);
SMA(CLOSE,SHORT,X)
SMA(CLOSE,SHORT,X)>SMA(CLOSE,LONG,X),BPK;
参数: X=1,LONG=22 SHORT=3
豆麦均线模型
MA2:=EMA(CLOSE,10);
MA1:=EMA(CLOSE,3);
CROSS(MA1,MA2),BK;
REF(MA1,1)-MA1>=3,SP;
CROSS(MA2,MA1),SK;
REF(MA1,1)-MA1<=2,BP;
均线差公式
MA1:=MA(CLOSE,3);
MA2:=MA(CLOSE,7);
FMA1:=REF(MA1,1);
FFMA1:=REF(MA1,2);
FMA2:=REF(MA2,1);
FFMA2:=REF(MA2,1);
CHA11:=FMA1-FFMA1;
CHA12:=MA1-FMA1;
CHA21:=FMA2-FFMA2;
CHA22:=MA2-FMA2;
CHA11>=0&&CHA12>=0,BPK;
CHA11+3<=0&&CHA12+3<=0||CHA21+2<=0&&CHA22+2<=0,SPK;
均线差公式2
MA1:=MA(CLOSE,3);
MA2:=MA(CLOSE,10);
CROSS(MA1,MA2),BK;
CROSS(MA2,MA1),SK;
CHA1:=MA1-REF(MA1,1);
CHA2:=REF(MA1,1)-REF(MA1,2);
CHA1<=0&&CHA2<=0,SP;
CHA1>=0&&CHA2>=0,BP;

分享到: