其他帐号登录: 注册 登录
收藏 | 网站
金融学院
欢迎阅读收藏并分享

文华财经期货指标公式代码经典形态之平台突破

29
发表时间:2019-04-19 16:53

MA8:=MA(CLOSE,8);
MA50:=MA(CLOSE,50);
PL1:=(((CLOSE - MA50) / MA50)<0.008);
PL2:=(((CLOSE - MA8) / MA8)<0.058);
偏离率:=(((PL1 = 1) AND (PL2 = 1)) * 0.2);
平台突破:=((((偏离率 = 0) AND (REF(偏离率,1) = 0.2)) AND (REF((COUNT((偏离率 = 0.2),10) = 10),1) = 1)) * 1);
XG:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
XG1:=REF(EMA(XG,3),1);
XG2:='KDJ.J'<50 AND C>REF(C,3);
A:=(C-MA(C,30))/MA(C,30)*100;
A1:=CROSS(0,(C-MA(C,5))/MA(C,5)*100);
A2:=A
A3:=MA(C,10)>REF(MA(C,10),1);
A4:=FILTER(A1 AND A2 AND A3,10);
A5:=(2*CLOSE+HIGH+LOW)/4;
A6:=MA(EMA((A5-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5),1);
B3:=REF(A4,2) AND CROSS(C,EMA(CLOSE,5)) ;
B4:=A6>REF(A6,1) AND REF(A6,1)
D:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
D1:=IF(CLOSE>OPEN,D*(HIGH-LOW),IF(CLOSE
D2:=IF(CLOSE>OPEN,D*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE
D3:='KDJ.J'<20 ;
E:= D1>D2*6 AND D3;
F1:=CROSS(CLOSE,XG1) AND XG2;
G2:=B3 AND B4;
平台突破 AND (F1 OR G2);

经典形态之平台突破


分享到: